Real bugs found by our tool

Github Repo: anouarbensaad/vulnx

Github Repo: msfidelis/CintoDeUtilidadesDocker

Github Repo: Azure/sonic-buildimage

Github Repo: rlworkgroup/garage

Github Repo: bisq-network/bisq

Github Repo: machine-drivers/docker-machine-driver-xhyve

Github Repo: apache/ignite

Github Repo: koding/koding

Github Repo: NVIDIA/nvvl

Github Repo: lordfriend/Albireo

Github Repo: InsightDataScience/ansible-playbook

Github Repo: RedisAI/RedisAI


     Detailed Reports


Dockerfile Index: 1
error on 51:apt-get -qq update \ apt-get install -qq -y --no-install-recommends \ python3 \ python3-pip
Expected '-q' or '-a' or '-t' or '-c' or '-o' or '-' or '--no-install-recommends' or '--install-recommends' or '--install-suggests' or '--no-install-suggests' or '--download-only' or '--fix-broken' or '--ignore-missing' or '--fix-missing' or '--no-download' or '--quiet' or '--quiet' or '--simulate' or '--just-print' or '--dry-run' or '--recon' or '--no-act' or '--yes' or '--assume-yes' or '--assume-no' or '--no-show-upgraded' or '--show-upgraded' or '--verbose-versions' or '--host-architecture' or '--build-profiles' or '--compile' or '--build' or '--ignore-hold' or '--with-new-pkgs' or '--upgrade' or '--no-upgrade' or '--only-upgrade' or '--allow-downgrades' or '--allow-remove-essential' or '--allow-change-held-packages' or '--force-yes' or '--print-uris' or '--purge' or '--reinstall' or '--list-cleanup' or '--no-list-cleanup' or '--target-release' or '--default-release' or '--trivial-only' or '--no-remove' or '--auto-remove' or '--autoremove' or '--only-source' or '--diff-only' or '--dsc-only' or '--tar-only' or '--arch-only' or '--indep-only' or '--allow-unauthenticated' or '--no-allow-insecure-repositories' or '--allow-insecure-repositories' or '--allow-releaseinfo-change' or '--show-progress' or '--with-source' or '--config-file' or '--option' or EOF at the position of the star(*) in => 'ate *apt-get in'.

Dockerfile Index: 2
error on 5:apt-get apt-get install nginx -y
Expected '-q' or '-a' or '-t' or '-c' or '-o' or '-' or '--no-install-recommends' or '--install-recommends' or '--install-suggests' or '--no-install-suggests' or '--download-only' or '--fix-broken' or '--ignore-missing' or '--fix-missing' or '--no-download' or '--quiet' or '--quiet' or '--simulate' or '--just-print' or '--dry-run' or '--recon' or '--no-act' or '--yes' or '--assume-yes' or '--assume-no' or '--no-show-upgraded' or '--show-upgraded' or '--verbose-versions' or '--host-architecture' or '--build-profiles' or '--compile' or '--build' or '--ignore-hold' or '--with-new-pkgs' or '--upgrade' or '--no-upgrade' or '--only-upgrade' or '--allow-downgrades' or '--allow-remove-essential' or '--allow-change-held-packages' or '--force-yes' or '--print-uris' or '--purge' or '--reinstall' or '--list-cleanup' or '--no-list-cleanup' or '--target-release' or '--default-release' or '--trivial-only' or '--no-remove' or '--auto-remove' or '--autoremove' or '--only-source' or '--diff-only' or '--dsc-only' or '--tar-only' or '--arch-only' or '--indep-only' or '--allow-unauthenticated' or '--no-allow-insecure-repositories' or '--allow-insecure-repositories' or '--allow-releaseinfo-change' or '--show-progress' or '--with-source' or '--config-file' or '--option' or 'update' or 'upgrade' or 'full-upgrade' or 'dselect-upgrade' or 'dist-upgrade' or 'check' or 'clean' or 'autoclean' or 'autoremove' or 'auto-remove' or 'install' or 'remove' or 'purge' or 'source' or 'build-dep' or 'download' or '-' or '--version' or '-' or '--help' at the position of the star(*) in => 'apt-get *apt-get in'.

Dockerfile Index: 3
error on 32:apt-get autoclean -
Expected 'd' or 'f' or 'm' or 'q' or 's' or 'y' or 'u' or 'V' or 'P' or 'b' at the position of the star(*) in => 'utoclean -*'.

Dockerfile Index: 4
error on 56:apt-get purge -y -v libglfw*
Expected 'd' or 'f' or 'm' or 'q' or 's' or 'y' or 'u' or 'V' or 'P' or 'b' or 'd' or 'f' or 'm' or 'q' or 's' or 'y' or 'u' or 'V' or 'P' or 'b' or 'd' or 'f' or 'm' or 'q' or 's' or 'y' or 'u' or 'V' or 'P' or 'b' at the position of the star(*) in => 'purge -y -*v libglfw*'.

Dockerfile Index: 5
error on 13:apt-get update && apt-get install -y --no-install-recommends openjfx && rm -rf /var/lib/apt/lists/* &&
Parsing Error: Unexpected 'EOF'
error on 14:apt-get install -y vim fakeroot
Unknow instruction "apt-get"

Dockerfile Index: 6
error on 3:
Parsing Error: Unexpected 'EOF'
error on 4:rabbitmq-plugins enable \ rabbitmq_shovel \ rabbitmq_shovel_management \ rabbitmq_federation \ rabbitmq_federation_management
Unknow instruction "rabbitmq-plugins"

Dockerfile Index: 7
In Repo: apache/ignite
error on 47:apt update && \ apt install -y --no-install-recommends \ nginx-light \ mongodb-org-server \ dos2unix && \ apt-get clean && \ rm -rf /var/lib/apt/lists/*
Unknow instruction "apt"

Dockerfile Index: 8
In Repo: koding/koding
error on 2:MAINTANER Igor Mihalik <igor.mihalik@gmail.com>
Unknow instruction "MAINTANER"

Dockerfile Index: 9
In Repo: NVIDIA/nvvl
error on 47:apt-get install -y wget &&
Parsing Error: Unexpected 'EOF'
error on 48:cd /tmp && \ wget https://github.com/opencv/opencv/archive/$OPENCV_VERSION.tar.gz && \ tar xf $OPENCV_VERSION.tar.gz && \ rm $OPENCV_VERSION.tar.gz && \ cd opencv-$OPENCV_VERSION && \ mkdir build && cd build && \ cmake -DCUDA_GENERATION=$OPENCV_CUDA_GENERATION \ $(for m in cudabgsegm cudacodec cudafeatures2d \ cudafilters cudalegacy cudaoptflow cudaobjdetect \ cudawarping cudev dnn features2d flann highgui ml \ objdetect photo python_bindings_generator shape \ superres ts video videoio; do echo -DBUILD_opencv_$m=OFF; done) \ $(for f in WEBP TIFF OPENEXR JASPER; do echo -DWITH_$f=OFF; done) \ .. && \ make -j8 && make install && \ ldconfig && \ cd /tmp && rm -rf opencv-$OPENCV_VERSION && \ apt-get purge -y wget && \ apt-get autoremove -y
Unknow instruction "cd"

Dockerfile Index: 10
In File: Dockerfile
error on 24:apt-get
Expected '-q' or '-a' or '-t' or '-c' or '-o' or '-' or '--no-install-recommends' or '--install-recommends' or '--install-suggests' or '--no-install-suggests' or '--download-only' or '--fix-broken' or '--ignore-missing' or '--fix-missing' or '--no-download' or '--quiet' or '--quiet' or '--simulate' or '--just-print' or '--dry-run' or '--recon' or '--no-act' or '--yes' or '--assume-yes' or '--assume-no' or '--no-show-upgraded' or '--show-upgraded' or '--verbose-versions' or '--host-architecture' or '--build-profiles' or '--compile' or '--build' or '--ignore-hold' or '--with-new-pkgs' or '--upgrade' or '--no-upgrade' or '--only-upgrade' or '--allow-downgrades' or '--allow-remove-essential' or '--allow-change-held-packages' or '--force-yes' or '--print-uris' or '--purge' or '--reinstall' or '--list-cleanup' or '--no-list-cleanup' or '--target-release' or '--default-release' or '--trivial-only' or '--no-remove' or '--auto-remove' or '--autoremove' or '--only-source' or '--diff-only' or '--dsc-only' or '--tar-only' or '--arch-only' or '--indep-only' or '--allow-unauthenticated' or '--no-allow-insecure-repositories' or '--allow-insecure-repositories' or '--allow-releaseinfo-change' or '--show-progress' or '--with-source' or '--config-file' or '--option' or 'update' or 'upgrade' or 'full-upgrade' or 'dselect-upgrade' or 'dist-upgrade' or 'check' or 'clean' or 'autoclean' or 'autoremove' or 'auto-remove' or 'install' or 'remove' or 'purge' or 'source' or 'build-dep' or 'download' or '-' or '--version' or '-' or '--help' at the position of the star(*) in => 'apt-get*'.

Dockerfile Index: 11
error on 21:git clone https://github.com/InsightDataScience/ansible-playbook.git /root
Unknow instruction "git"
error on 23:mkdir -p /etc/ansible/hosts
Unknow instruction "mkdir"

Dockerfile Index: 12
In Repo: RedisAI/RedisAI
error on 12:apt-get -q install -y
Unknow instruction "apt-get"
error on 13:git tar wget curl \ build-essential cmake \ python3 python3-pip python3-dev \ libcurl4-openssl-dev libssl-dev libatlas-base-dev
Unknow instruction "git"
error on 11:apt-get -qq update \;
Expected '-q' or '-a' or '-t' or '-c' or '-o' or '-' or '--no-install-recommends' or '--install-recommends' or '--install-suggests' or '--no-install-suggests' or '--download-only' or '--fix-broken' or '--ignore-missing' or '--fix-missing' or '--no-download' or '--quiet' or '--quiet' or '--simulate' or '--just-print' or '--dry-run' or '--recon' or '--no-act' or '--yes' or '--assume-yes' or '--assume-no' or '--no-show-upgraded' or '--show-upgraded' or '--verbose-versions' or '--host-architecture' or '--build-profiles' or '--compile' or '--build' or '--ignore-hold' or '--with-new-pkgs' or '--upgrade' or '--no-upgrade' or '--only-upgrade' or '--allow-downgrades' or '--allow-remove-essential' or '--allow-change-held-packages' or '--force-yes' or '--print-uris' or '--purge' or '--reinstall' or '--list-cleanup' or '--no-list-cleanup' or '--target-release' or '--default-release' or '--trivial-only' or '--no-remove' or '--auto-remove' or '--autoremove' or '--only-source' or '--diff-only' or '--dsc-only' or '--tar-only' or '--arch-only' or '--indep-only' or '--allow-unauthenticated' or '--no-allow-insecure-repositories' or '--allow-insecure-repositories' or '--allow-releaseinfo-change' or '--show-progress' or '--with-source' or '--config-file' or '--option' or EOF at the position of the star(*) in => 'qq update *\;'.